Forums Community

These forums are dedicated to the discussion of our DotNetNuke products, such as Ultimate DNN Blog Module - SunBlogNuke & GalleryPlus.

For the benefit of the community and to keep information here helpful to everyone who visits, please observe the following posting guidelines:

  • If you are reporting a bug and strange issue please tell us which version of DNN and SunBlogNuke and share some event logs from "Admin/Event Viewer".
  • Site Moderators have the final word on approving/removing a thread or post or comment.
  • English language posting only, please.
Home/Ultimate DNN Blog Module :: SunBlogNuke/Support Issues/Divide by Zero Error
PreviousNext
New Post
6/18/2011 6:16 AM
 

Hi there,

I seem to have a problem with the latest version of Sunblognuke - 4.6.2 on DNN 05.06.02

When installed and the module added to a page, I get "A CRITICAL ERROR HAS OCCURED, Attempted to divide by zero".

This happens with a fresh install, and when I put on an older verion, create a couple of dummy posts and then upgrade.

Any ideas?

Regards

Craig

New Post
6/18/2011 9:28 AM
 

Hi Craig,

Could you send the event log about this error? And you should find it in the Admin->Event Logs page. Thanks.

Kind regards

Baldwin


Ultimate DNN Blog Module - SunBlogNuke
New Post
6/22/2011 11:30 PM
 

I am having the same problem as Craig and thought I will just paste my Event log:

AssemblyVersion: 5.2.2PortalID: 4PortalName: BreakThrough Community Church - Kansas City, KS - USAUserID: 1UserName: hostActiveTabID: 900ActiveTabName: YABRawURL: /YAB/tabid/900/language/en-US/Default.aspxAbsoluteURL: /Default.aspxAbsoluteURLReferrer: http://www.bccsite.us/YAB/tabid/900/language/en-US/Default.aspxUserAgent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.2)DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProviderExceptionGUID: 7d45ddb0-2af0-49de-900d-ad64c553d04dInnerException: Attempted to divide by zero.FileName: FileLineNumber: 0FileColumnNumber: 0Method: SunBlogNuke.Toolkit.WebControls.SimplePagingControl.BindPageNumbersStackTrace: Message: DotNetNuke.Services.Exceptions.PageLoadException: Attempted to divide by zero. ---> System.DivideByZeroException: Attempted to divide by zero. at SunBlogNuke.Toolkit.WebControls.SimplePagingControl.BindPageNumbers(Int32 TotalRecords, Int32 RecordsPerPage) at SunBlogNuke.Toolkit.WebControls.SimplePagingControl.CreateChildControls() at System.Web.UI.Control.EnsureChildControls() at System.Web.UI.Control.FindControl(String id, Int32 pathOffset) at System.Web.UI.Control.FindControl(String id) at ASP.portals_4_containers_bcc2011silver_block_ascx.ReplaceHelpIcon(Control ctl) at ASP.portals_4_containers_bcc2011silver_block_ascx.ReplaceHelpIcon(Control ctl) at ASP.portals_4_containers_bcc2011silver_block_ascx.ReplaceHelpIcon(Control ctl) at ASP.portals_4_containers_bcc2011silver_block_ascx.ReplaceHelpIcon(Control ctl) at ASP.portals_4_containers_bcc2011silver_block_ascx.ReplaceHelpIcon(Control ctl) at ASP.portals_4_containers_bcc2011silver_block_ascx.ReplaceHelpIcon(Control ctl) at ASP.portals_4_containers_bcc2011silver_block_ascx.Page_PreRender(Object sender, EventArgs e) at System.Web.UI.Control.OnPreRender(EventArgs e) at DotNetNuke.UI.Containers.Container.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) --- End of inner exception stack trace ---

New Post
6/24/2011 4:27 PM
 
There seem to be the issue in some dnn version but we can not reproduce it in our side. Now you can install the older version, such as 3.5.8.  We will try to fix it soon. Hope it makes sense.

Ultimate DNN Blog Module - SunBlogNuke
New Post
6/24/2011 6:30 PM
 

Hi,

Interestingly I got it working earlier. 

  1. Install fresh DNN
  2. Install Sunblognuke
  3. Put sunblognuke on homepage - no errors, everything is OK.
  4. Load a custom skin - get divide by zero error
  5. Go back to native skin - error still there.

I've tried this a couple of times and it always does the same.  V strange.  Once it's broke it seems to stay broke.

I could send you a copy of the skin if it would help.

Regards

Craig

New Post
6/24/2011 7:55 PM
 
Thanks a lot for your information. Appreciate much if you can send the copy of the customized skin. We will try to look into the issue later.

Ultimate DNN Blog Module - SunBlogNuke
New Post
7/7/2011 6:56 AM
 

We're getting the exact same error as we downloaded and installed SunBlogNuke_Enterprise_4.7.1_Install_for_DNN5.x.zip for our intranet we've been working on... which is DNN 5.6.2 Pro

And for us it does not matter about the skin... we get the error on both DNN install skin and  or our new skin... so it doesn't make any difference for us. SunblogNuke 4.7.1 does not work.

Please advise what we should do as we are to demo this to executives on FRIDAY.

Should we uninstall and download and install version SunBlogNuke v4.5? or v4.4.5 or v4.4.5 or earlier?

Please advise...as soon as possible.

Thanks

New Post
7/7/2011 7:04 AM
 
Now you can install the older version, such as 3.5.8. Note that you need to uninstall it firstly. Hope it makes sense.

Ultimate DNN Blog Module - SunBlogNuke
New Post
7/7/2011 1:26 PM
 

I uninstalled 4.7.X of SunBlogNuke and got a MAJOR ERROR... could not access the site. To Fix i went through all of the web.config and removed anything that said SunBlogNuke.... after that, the site came back up... OH JOY! and WHEW! we continued to uninstall the rest of the modules.

Then we installed a version we know works with DNN 5.6.2 which was SunBlogNuke 4.4.0 and it works fine... but we would really like to be using the latest version 4.7.x

Will we ever get to use it? Also could the issue be that you may have some hidden code trying to reach outside the firewall thus sending off the error of "Divide by Zero Error"? Our intranet is very tightly secure. Just a thought.

Any ideas what could be causing this and when its going to be fixed?... looking forward to using the latest version of SunBlogNuke... please let us know.

Thanks

New Post
7/7/2011 1:52 PM
 

Hi Reggfx,

We can not reproduce it in our side with dnn 5.6.2 and it is indeed a strange issue. We will try to debug why but now there is no any way to track it except that skin package. Hope it makes sense.

Regards

Baldwin


Ultimate DNN Blog Module - SunBlogNuke
New Post
7/7/2011 8:02 PM
 

Hello,

Yes this is strange... because version 4.4.0 of SunBlogNuke works with the same skin and "NO" errors... so there may be something new in 4.7.x that produces a conflict... and what that is i have no way of finding.

I just sent you an email of the skin files, please let us know something soon.

Thanks so much for your help in resolving this matter.

New Post
7/11/2011 1:56 PM
 

Hi All,

Just would like to let you know that the bug have been found and the fixed version will be available tomorrow. Hope it makes sense.

Thanks lot for Craig's help.

Regards

Baldwin


Ultimate DNN Blog Module - SunBlogNuke
New Post
7/12/2011 3:32 PM
 
The v4.7.2 with fixing the issue is available to download now. Please refer to the post - http://www.sunblognuke.com/blog/entryid/408/important-fixed-version-for-sunblognuke.aspx.

Ultimate DNN Blog Module - SunBlogNuke
PreviousNext
Home/Ultimate DNN Blog Module :: SunBlogNuke/Support Issues/Divide by Zero Error
Order posts from:
Copyright © 2009-2014 Ultimate DNN Blog Module - SunBlogNuke Powered by SunBlogNuke Corp